View unanswered posts | View active topics It is currently Sun Apr 20, 2014 2:57 pm



Reply to topic  [ 2 posts ] 
 Thermostat Wiring Question 
Author Message

Joined: May 12, 2008
Posts: 23
Location: Georgia, USA
Post Thermostat Wiring Question
First let me apologize... Doing a search indicates that the answer is probably already posted, but reading through a lot of the info I was getting confused so I thought it best to ask in a new thread:

I purchased a home and am getting all of my equipment set back up to be controlled by Indigo. The one "hiccup" I'm having is figuring out the thermostat in the new place, and I think it just comes from a lack of knowledge of HVAC systems in general. I have the Venstar T1700 and the T1900, but I have not been able to decode the existing thermostat's connections to know exactly how to hook either up. This is what is currently in place:

R (connected to a red wire)
G (connected to a green wire)
O (connected to an orange wire)
Y (connected to a yellow wire)
E (connected to a white wire)

My understanding, then, is that R is the power, G controls the fan, O controls the reversing valve (?), Y controls the emergency heat (?), and white is, perhaps, common (?).

When I hooked up the T1900 according to the above idea I never received anything on the display, as though the thermostat was not receiving any power. I did not try hooking up the T1700 because it was still packed away.

My question, then, becomes more of a guide for what I should be hooking up. Does anyone have any experience with five wire systems and the corresponding setup on the Venstar units? Should I, perhaps, be adjusting the jumpers as well?

Attached is a picture of the existing wiring to the existing thermostat.


Attachments:
File comment: Existing Wiring
IMG_0111.jpg
IMG_0111.jpg [ 159.59 KiB | Viewed 126 times ]
Sat Oct 22, 2011 8:34 am
Profile WWW

Joined: May 12, 2008
Posts: 23
Location: Georgia, USA
Post Re: Thermostat Wiring Question
For reference, I figured out what the issue was:

The original thermostat ran on batteries, so the common wire was never hooked up. Hooked up the common, wired the thermostat correctly, and done.

In case anyone else encounters it, here is the correct wiring connection for this particular hookup:

R to R (Power)
G to G (Blower)
O to O (Reversing Valve)
Y to Y (Compressor / Cooling)
E to W2 (Aux/Emergency Heat)
C to C (this one was the missing link)


Sat Oct 22, 2011 1:28 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: Google Feedfetcher, Shutter and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.   Template designed by STSoftware.