View unanswered posts | View active topics It is currently Thu Apr 17, 2014 9:26 am



Reply to topic  [ 33 posts ]  Go to page: 1, 2, 3  Next
 Touch Connection Question 
Author Message

Joined: Feb 25, 2008
Posts: 207
Location: Los Angeles, CA
Post Touch Connection Question
I find myself in that small group of people unable to connect to my local Indigo server using Touch.

As the iPhone would not automatically sense it using Bonjour (which seems to be the preferred way), I called Apple. They told me to set up a WiFi network using Airport. It did not go well – my iPhone would now sense the local Indigo server name (an improvement), but be unable to connect (it would try using the Edge network (?) and then say “Timed Out. Connection to Indigo Server failed: Macintosh.local.” After six calls and two hours of circling, Apple gave up and said to call my ISP for a router and then call them back.

Next I tried manually adding the server. I followed the directions on Page 12 of the manual (e.g., getting the number from Filing Sharing), added “:8176” at the end…and again got the timeout error.

Next I tried manually adding the server using my Prism URL. I took this from the Start Local Server dialogue box (e.g., copied the Reflector address starting with https), added “:80” at the end (going by forum topic “4201”)…and this time was told “Secure Connection Failed. Connection to Indigo Server failed: [URL].”

What am I doing wrong?

(Also, is one of these “better” than the others, meaning I should keep that one of the three and delete the other two nonfunctional Indigo Servers from my Touch’s list?)

Thank you,


Fri Apr 24, 2009 12:44 pm
Profile
Site Admin
User avatar

Joined: Mar 19, 2008
Posts: 8350
Location: Austin, Texas
Post 
I suspect that you're Firewall is blocking the connection. Read through this thread paying special attention to the posts about firewall settings.

I'm gonna add a troubleshooting Indigo Touch connectivity Wiki article at some point since these firewall settings seem to be causing non-trivial pain.

_________________
Jay (Indigo Support)
Image


Fri Apr 24, 2009 1:56 pm
Profile WWW

Joined: Feb 25, 2008
Posts: 207
Location: Los Angeles, CA
Post 
Thank you, Jay. I looked over the linked thread, but do not see anything that obviously affects me:

In the Apple firewall, both Python.app and IndigoServer.app are already listed as allowed.

I do have another firewall product, but it is set to check with me on any “intrusion request.” Further, its anti-spyware preferences list both Python (ports 80 and 8176) and Indigo Server (twice? ports 80 and 110, and then 110 and 995) as permitted. [Not sure why those specific reports are listed, but doubt it’s the problem, because…]

I have no difficulties when using Prism on the web (via either home, work, or iPhone).

I’ve tried restarting both the computer and the phone.

I also tried Matt’s suggestion of
support wrote:Inside Indigo Touch, try the following:
1) Choose Settings.
2) Press Edit and delete all of the connections (except Demo Server which isn't delete-able).
3) Quit Indigo Touch.
4) Relaunch.
5) What does the Settings panel show? Did "My House 1" re-appear?
6) If it did, select it -- does it work?


Nothing appeared until I turned on Airport. Now my server was detected, but I got the error “Timed out.” I then tried with Airport turned off, and got “Unable to connect to local Indigo Server” plus an endless spinning wheel. I then re-added the IP address+:8176, and still got the Timed out error. I then re-added the https://[prism address]+:80, and still got the “Secure connection failed” error.

Would you or anyone else have any other suggestions?

Thank you,


Mon Apr 27, 2009 10:05 pm
Profile
Site Admin
User avatar

Joined: Mar 19, 2008
Posts: 8350
Location: Austin, Texas
Post 
Snakesitter wrote:I do have another firewall product, but it is set to check with me on any “intrusion request.” Further, its anti-spyware preferences list both Python (ports 80 and 8176) and Indigo Server (twice? ports 80 and 110, and then 110 and 995) as permitted. [Not sure why those specific reports are listed, but doubt it’s the problem, because…]


While you're diagnosing the problem, I'd suggest turning off the other firewall just to remove one factor. I'm not sure but it seems to me that 2 different firewall products running on the same machine might very well be causing some confusion... ;)

Snakesitter wrote:Nothing appeared until I turned on Airport. Now my server was detected, but I got the error “Timed out.” I then tried with Airport turned off, and got “Unable to connect to local Indigo Server” plus an endless spinning wheel. I then re-added the IP address+:8176, and still got the Timed out error. I then re-added the https://[prism address]+:80, and still got the “Secure connection failed” error.


So, your computer has both a wired network connection and a wireless connection? And, when you have the wireless turned off, you don't get any connection? I'm just a little confused about your network topology I guess - can you describe it in more detail?

_________________
Jay (Indigo Support)
Image


Mon Apr 27, 2009 10:44 pm
Profile WWW

Joined: Feb 25, 2008
Posts: 207
Location: Los Angeles, CA
Post 
No, I connect to the Internet only through a wired connection, via DSL from Verizon using a modem they provided. It is this connection that permits me to use Prism.

The wireless part came around because I was trying to get a Bonjour connection between my Mac and iPhone, and called Apple to help set this up (yeah Applecare!). They suggested the Airport idea...then later changed their minds. Turning this off stops whatever connection is allowing me to automatically sense the Indigo server.

Is that enough detail?

Will try turning off the second firewall tonight. But for a long time (more than six months of using Prism) it was only the second party firewall that as active; I just turned on the Apple one last week.

Thank you,


Tue Apr 28, 2009 12:45 am
Profile
Site Admin
User avatar

Joined: Jan 27, 2003
Posts: 13210
Location: Texas
Post Re: Touch Connection Question
Snakesitter wrote:Next I tried manually adding the server using my Prism URL. I took this from the Start Local Server dialogue box (e.g., copied the Reflector address starting with https), added “:80” at the end (going by forum topic “4201”)…and this time was told “Secure Connection Failed. Connection to Indigo Server failed: [URL].

If you are entering the complete URL including the HTTPS:// then do not append the :80 on to the end. Port 80 is only for HTTP traffic, so requesting that it use HTTPS and port 80 is not going to work. Appending the port number on the end is required if: you do not enter the protocol type (HTTP or HTTPS), or the port number is not the standard HTTP or HTTPS port number. For GoPrism.com it does use the normal port numbers, so just enter the full URL with HTTPS and no port number.

For true LAN access (not via GoPrism.com) definitely do turn off that second firewall. I have a sneaky suspicion that is causing the problem. GoPrism.com avoids all firewall (not quite all, but just about) problems because it establishes an outgoing secure connection to our hosted server in Vegas. Incoming connections when on a LAN (via Bonjour + WiFi) are much more likely to be blocked by a firewall. I not positive it is going to work without an Airport access point though; you may just have to connect via GoPrism.com.

_________________
Image


Last edited by matt (support) on Tue Apr 28, 2009 7:26 am, edited 1 time in total.



Tue Apr 28, 2009 7:05 am
Profile WWW
Site Admin
User avatar

Joined: Mar 19, 2008
Posts: 8350
Location: Austin, Texas
Post 
Snakesitter wrote:The wireless part came around because I was trying to get a Bonjour connection between my Mac and iPhone, and called Apple to help set this up (yeah Applecare!). They suggested the Airport idea...then later changed their minds. Turning this off stops whatever connection is allowing me to automatically sense the Indigo server.


OK, so your network looks something like this:

Mac <-> DSL Modem <-> Internet <-> iPhone (via 3G/Edge)

Right?

I think we've found the problem. Because your Mac is directly connected to the DSL modem (rather than through a router), you don't have a local network at your house: therefore, bonjour won't work because your iPhone will be connecting via 3G/Edge, not WiFi, and bonjour only works on local networks.

Apple was trying to set up your Mac so that it would create a local WiFi network so that your iPhone could connect to it and therefore see the bonjour advertisement.

In your situation, the easiest way to connect is just connect directly to your goprism reflector. So, try this:

1) Disable Airport on your Mac
2) In Indigo Touch, touch Settings
3) Touch Edit and delete all of the connections (except Demo Server which isn't delete-able).
4) Quit Indigo Touch.
5) Relaunch.
6) Touch Settings
7) Touch Manually Add Server
8) Enter your prism account information (i.e. https://youraccounthere.goprism.com/)
9) Touch Done (at the bottom)
10) Touch Done (at the top)

You should see everything, yes?

_________________
Jay (Indigo Support)
Image


Tue Apr 28, 2009 7:24 am
Profile WWW

Joined: Feb 25, 2008
Posts: 207
Location: Los Angeles, CA
Post 
support wrote:If you are entering the complete URL including the HTTPS:// then do not append the :80 on to the end.


support wrote:I not positive it is going to work without an Airport access point though; you may just have to connect via GoPrism.com.


jay wrote:In your situation, the easiest way to connect is just connect directly to your goprism reflector. So, try this...You should see everything, yes?


Ah-ha, you two have solved it! Removing the :80 allowed it to work perfectly, and I can now access the network fine.

Thank you both for your time,


Tue Apr 28, 2009 2:40 pm
Profile

Joined: May 19, 2005
Posts: 23
Post Indigo Touch Connection Issues
it seems this problem still exists in 4.1.1.

It seems the server name is only broadcast when the indigo server starts - if the ipod touch is shut off or cycled through other apps returning to indigo will yield a connection error.

Restart the server and everything connects.


Tue Nov 03, 2009 5:33 am
Profile
Site Admin
User avatar

Joined: Mar 19, 2008
Posts: 8350
Location: Austin, Texas
Post Re: Indigo Touch Connection Issues
masterbaron wrote:it seems this problem still exists in 4.1.1.

It seems the server name is only broadcast when the indigo server starts - if the ipod touch is shut off or cycled through other apps returning to indigo will yield a connection error.

Restart the server and everything connects.


As you can see from the thread above, Snakesitter had a configuration problem that solved his problem. Can you describe exactly what happens and how your network is configured?

_________________
Jay (Indigo Support)
Image


Tue Nov 03, 2009 8:10 am
Profile WWW

Joined: May 19, 2005
Posts: 23
Post 
First - everything worked well in prior versions to 4.1.1.

Mac G5 - Linksys Dual-Band - Netgear switch - IPod Touch 3.1.2

When Indigo server first starts - the Touch connects - once I use another app on the Touch and return to Indigo the Touch is unable to connect ... the wheel just spins - restarting the server again will cause the Touch to seize the connection again as it should.

I've re-installed Indigo and just installed Indigo for Touch 1.5.0 and the problem still exists.


Sat Nov 07, 2009 9:37 pm
Profile

Joined: May 19, 2005
Posts: 23
Post Touch Connection issues
The firewall is set to allow connections for python and indigo.
I also setup port forwarding in the router.


Sun Nov 08, 2009 6:56 am
Profile

Joined: May 19, 2005
Posts: 23
Post 
The firewall log does not append with new information when i launch indigo - when i launch another network service like slimserver the log appends with new information about the connection requests.

This makes me think it has to do with the touch app until i think about the fact that restarting the server instantly restores to a working connection ... something about the bonjour broadcasting or the server turns a deaf ear???

HELP!!!


Sun Nov 08, 2009 7:29 am
Profile

Joined: May 19, 2005
Posts: 23
Post 
There are a lot of posts about connection issues recently .. this says something is not quite right!!


Sun Nov 08, 2009 7:33 am
Profile
Site Admin
User avatar

Joined: Mar 19, 2008
Posts: 8350
Location: Austin, Texas
Post 
masterbaron wrote:The firewall log does not append with new information when i launch indigo - when i launch another network service like slimserver the log appends with new information about the connection requests.

This makes me think it has to do with the touch app until i think about the fact that restarting the server instantly restores to a working connection ... something about the bonjour broadcasting or the server turns a deaf ear???

HELP!!!


This does sound like a firewall issue. For testing purposes, temporarily turn off you firewall and see if the problem persists. Let us know what you find.

_________________
Jay (Indigo Support)
Image


Sun Nov 08, 2009 8:08 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 33 posts ]  Go to page: 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.   Template designed by STSoftware.